Konfigurasi OSPF Single Area Di GNS3

Pada aktifitas lab kali ini saya menggunakan GNS3. Anda juga dapat menggunakan Packet Tracer untuk ngelab OSPF Single Area ini. :)
Berikut topologi untuk konfigurasi OSPF Single Area


Tujuan
  • Mensetting routing protocol OSPF Singe-Area di R1 dan R2
  • Mensetting interface loopback di R1 dan R2
Langkah Konfigurasi

IP address S0/0 R1 = 12.12.12.1/30
IP address S0/0 R2 = 12.12.12.2/30

R1#conf t
R1(config)#int s0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.252
R1(config-if)#clock rate 2000000
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#int lo0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#

R2#conf t
R2(config)#int s0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int lo0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#exit
R2(config)#

Interface loopback pada lab ini berfungsi sebagai virtual subnet. Sehingga seolah-olah kita memiliki 1 subnet yang dihubungkan melalui koneksi serial antara R1 dan R2. Loopback sangat bermanfaat untuk nge-lab jika resource computer kita minimal, sehingga tidak perlu menggunakan jumlah router yang banyak.

Pada semua design network OSPF yang bagus, backbone area biasanya disetting sebagai area 0. Maka, area 0 sering disebut juga sebagai backbone area, karena berfungsi untuk mengkoneksikan antar area.

Untuk mensetting OSPF routing protocol gunakan command router ospf process-id. Proses ID hanya berlaku untuk local router, sehingga tidak berpengaruh untuk router lain. Proses ID boleh beda antar router dan dalam satu router bisa menjalankan multiple proses ID. Setelah itu setting dengan sub-command network address wildcard-mask area area-id. Tentukan network address yang akan diadvertised menggunakan OSPF. Dalam satu area-id, router harus memiliki area-id yang sama sehingga bisa membentuk adjacency.

Konfigurasi routing OSPF

R1(config)#router ospf 1
R1(config-router)#network 12.12.12.0 0.0.0.3 area 0
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0

R2(config)#router ospf 1
R2(config-router)#network 12.12.12.0 0.0.0.3 area 0
R2(config-router)#network 192.168.2.0 0.0.0.255 area 0

Wildcard mask 0.0.0.0 artinya harus match. Wildcard mask 0.0.0.3 artinya hanya 3 oktet yang match dan octet keempat ignored. Contoh untuk network 12.12.12.0 0.0.0.3 area 0 artinya 12.12.12.1 sampai 12.12.12.2. Pada wildcard mask lain misal 0.0.0.255, Anda dapat mengkonfigurasi IP address apa saja yang berada pada range 192.168.1.1 – 192.168.1.254 untuk di area 0 pada interface s0/0 R1.

Karena pada lab ini menggunakan OSPF Single-Area yaitu area 0, maka semua router harus memiliki area yang sama agar bisa membentuk adjacency sehingga semua network dapat berkomunikasi. Untuk area yang sama biasanya disebut juga Intra Area, sedangkan untuk area yang berbeda Inter Area.

Verifikasi

Kita lihat tabel routing pada R1 dengan mengetikkan perintah "show ip route".


Untuk OSPF kodenya O. Lihat pada kode O, network address 192.168.2.0 ada di R2. Untuk menuju ke network tersebut dari R1 menggunakan jalur 12.12.12.2. IP 12.12.12.2 merupakan IP address s0/0 R2. “via” artinya gateway yang mau dilewati / lewat mana. Simplenya untuk menuju ke network 192.168.2.0 melalui 12.12.12.2.

Untuk output agar spesifik routing OSPF saja yang ditampilkan bisa menggunakan command dibawah : "show ip route ospf"

Metric OSPF pada Lab ini yaitu 65, sedangkan Administrative Distance OSPF = 110. Dapat dilihat pada baris berikut:

O 192.168.2.1 [110/65] via 12.12.12.2, 00:00:56, Serial0/0

R1 secara dinamis mempelajari remote network pada R2 melalui next hop address 12.12.12.2 dan outbound interface Serial 0/0. OSPF membentuk neighborship dengan adjacent router dengan melakukan pertukaran Paket Type 1 (Hello). Berikut ini kondisi yang harus dipenuhi oleh dua router untuk membentuk neighbor:
  • Masing-masing router harus berada pada subnet yang sama dan menggunakan subnet mask yang sama
  • Masing-masing router harus memiliki hello dan dead intervals yang sama
    • Hello interval mengidentifikasikan berapa frekuensi neighbor router melakukan pertukaran hello packet
    • Dead interval mengidentifikasikan jumlah waktu yang diijinkan tanpa mengirimkan hello packet.
    • Note: jika secara periodic hello packet tidak diterima dalam jangka waktu dead interval, maka router mengasumsikan bahwa neighbor router telah offline.
  • Masing-masing router harus menggunakan area yang sama
  • Jika autentikasi dibutuhkan, masing-masing router harus memenuhi requirement autentikasi
Adjacent router adalah router yang menjadi tetangga (neighbor) dan akan melakukan sharing atau pertukaran informasi database yang dimiliki.

Ping dari S0/0 R1 ke Interface Loopback 2 di R2 :

0 comments

Post a Comment