Konfigurasi OSPF Multi Area Di GNS3

Pada artikel sebelumnya saya sudah memposting konfigurasi OSPF Single Area. Pada artikel kali ini saya akan mencoba membagi Konfigurasi OSPF Multi Area. Saya masih memakai software GNS3 untuk ngelab kali ini. Berikut topologi yang akan digunakan,


Area 0 : antara R1 – R2
Area 1 : antara R2 – R3
Area 2 : antara R2 – R4

Internal Router = R1, R3, R4 -> semua interface berada pada area yang sama
Area Border Router (ABR) = R2 -> berfungsi menghubungkan dua area yang berbeda
Backbone Router = R1, R2 -> area yang terkoneksi ke area 0, disebut juga area 0.0.0.0

Tujuan

  • Mensetting routing protocol OSPF Multi Area di R1, R2, R3, R4
  • Mensetting interface loopback di R1, R2, R3 dan R4
  • Mensetting OSPF Multi Area di R2
Langkah Konfigurasi

IP address s0/0 R1 = 12.12.12.1/30
IP address s0/0 R2 = 12.12.12.2/30

IP address S0/1 R2 = 23.23.23.2/30
IP address S0/2 R2 = 24.24.24.2/30

IP address S0/0 R3 = 23.23.23.1/30
IP address S0/0 R4 = 24.24.24.1/30

R1#conf t
R1(config)#int s0/0
R1(config-if)#ip add 12.12.12.1 255.255.255.252
R1(config-if)#clock rate 2000000
R1(config-if)#no sh
R1(config-if)#exit
R1(config)#int lo0
R1(config-if)#ip add 1.1.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#

R2#conf t
R2(config)#int s0/0
R2(config-if)#ip add 12.12.12.2 255.255.255.252
R2(config-if)#no sh
R2(config-if)#exit
R2(config)#int s0/1
R2(config-if)#ip add 23.23.23.2 255.255.255.252
R2(config-if)#clock rate 2000000
R2(config-if)#no sh
R2(config-if)#exit
R2(config)#int s0/2
R2(config-if)#ip add 24.24.24.2 255.255.255.252
R2(config-if)#clock rate 2000000
R2(config-if)#no sh
R2(config-if)#exit
R2(config)#int lo0
R2(config-if)#ip add 2.2.2.1 255.255.255.0
R2(config-if)#exit
R2(config)#int lo1
R2(config-if)#ip add 5.5.5.1 255.255.255.0
R2(config-if)#exit
R2(config)#

R3#conf t
R3(config)#int s0/0
R3(config-if)#ip add 23.23.23.1 255.255.255.252
R3(config-if)#no sh
R3(config-if)#exit
R3(config)#int lo0
R3(config-if)#ip add 3.3.3.1 255.255.255.0
R3(config-if)#exit
R3(config)#

R4#conf t
R4(config)#int s0/0
R4(config-if)#ip add 24.24.24.1 255.255.255.252
R4(config-if)#no sh
R4(config-if)#exit
R4(config)#int lo0
R4(config-if)#ip add 4.4.4.1 255.255.255.0
R4(config-if)#exit
R4(config)#

Konfigurasi Routing OSPF di masing-masing Router

R1(config)#router ospf 1
R1(config-router)#network 1.1.1.0 0.0.0.255 area 0
R1(config-router)#network 12.12.12.0 0.0.0.3 area 0

R3(config)#router ospf 3
R3(config-router)#network 3.3.3.0 0.0.0.255 area 1
R3(config-router)#network 23.23.23.0 0.0.0.3 area 1

R4(config)#router ospf 4
R4(config-router)#network 4.4.4.0 0.0.0.255 area 2
R4(config-router)#network 24.24.24.0 0.0.0.3 area 2

R2(config)#router ospf 2
R2(config-router)#network 2.2.2.0 0.0.0.255 area 0
R2(config-router)#network 5.5.5.0 0.0.0.255 area 0
R2(config-router)#network 12.12.12.0 0.0.0.3 area 0
R2(config-router)#network 23.23.23.0 0.0.0.3 area 1
R2(config-router)#network 24.24.24.0 0.0.0.3 area 2

Verifikasi

Menampilkan OSPF routing table di R1


Dari hasil perintah "show ip route ospf" terlihat kode "O IA" yang berarti OSPF Inter Area. Masukkan perintah tersebut untuk mengetahui tabel routing di R2, R3, dan R4.
Kita juga dapat melihat router ABR dengan menggunakan perintah "show ip ospf border-routers"




Pastikan Interface loopback di R1 bisa nge-ping interface loopback pada R3 dan R4


Pastikan juga R3 dapat nge-ping Interface Loopback 0 di R1. Begitu juga dengan R4 harus bisa nge-ping Interface Loopback 0 di R1


Catatan untuk OSPF : bahwa semua area harus terkoneksi ke backbone. Jika terdapat area yang tidak terkoneksi secara langsung ke backbone (misal: Area 2 terkoneksi ke Area 1 via R3), maka dibutuhkan virtual link. Ketika mendesain jaringan, Anda dapat menggunakan virtual link untuk mengkoneksikan area yang tidak terhubung langsung ke backbone secara fisik.

File Lab GNS3 OSPF Multi Area dapat di download disini.

0 comments

Post a Comment