EIGRP OSPF Redistribution

Sudah lama tidak ngepost tentang Lab Cisco. Berikut saya akan mencoba ngelab redistribution EIGRP dan OSPF. Lab ini biasanya keluar di CCNP Route Exam. (CCNP ROUTE 642-902)



Tujuan dari lab ini adalah:
  • Redistribute dari EIGRP ke OSPF dan sebaliknya
  • R1 harus sukses ping ke alamat loopback0 R4 (172.16.100.1)
  • Trafik dari R1 ke R4 harus melalui jalur yang terbaik. (Setelah konfig redistribution dimasukkan, trafik dari R1 akan melalui R1 -> R2 -> R4; hal ini bukan jalur yang paling optimal karena harus melalui 2 link serial. Jalur terbaik adalah R1 -> R2 -> R3 -> R4 dan kita harus mengkonfigurasi router R2 agar trafik bisa diteruskan ke R3.)
Konfigurasi IP Address dan routing protokol di masing-masing router:

R1
R1(config)#interface s0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#router eigrp 100
R1(config-router)#network 192.168.1.0


R2
R2(config)#interface s0/1
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#interface f1/0
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#interface s0/0
R2(config-if)#ip address 192.168.3.3 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#router eigrp 100
R2(config-router)#network 192.168.1.0
R2(config-router)#network 192.168.2.0
R2(config-router)#exit
R2(config)#router ospf 1
R2(config-router)#network 192.168.3.0 0.0.0.255 area 24


R3
R3(config)#interface f0/0
R3(config-if)#ip address 192.168.2.3 255.255.255.0
R3(config-if)#no shut
R3(config-if)#interface f1/0
R3(config-if)#ip address 192.168.4.3 255.255.255.0
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#router eigrp 100
R3(config-router)#network 192.168.2.0
R3(config-router)#exit
R3(config)#router ospf 1
R3(config-router)#network 192.168.4.0 0.0.0.255 area 34


R4
R4(config)#interface s0/0
R4(config-if)#ip address 192.168.3.4 255.255.255.0
R3(config-if)#interface f1/0
R3(config-if)#ip address 192.168.4.4 255.255.255.0
R4(config-if)#no shut
R3(config-if)#interface loopback0
R3(config-if)#ip address 172.16.100.1 255.255.255.0
R4(config-if)#exit
R4(config)#router ospf 1
R4(config-router)#network 192.168.3.0 0.0.0.255 area 24
R4(config-router)#network 192.168.4.0 0.0.0.255 area 34
R4(config-router)#network 172.16.100.0 0.0.0.255 area 0

Setelah menyelesaikan perintah awal di atas, tabel routing masing-masing router adalah sebagai berikut:

R1:


R2:


R3:


R4:

Masukkan konfigurasi untuk redistribute di R2 dan R3. Sebelumnya kita harus melihat parameter yang dibutuhkan untuk redistribute dari OSPF ke EIGRP. Pada serial interface S0/0 R2 (yang terhubung ke R4), terdapat 5 parameter (Bandwidth, Delay, Reliability, Load, MTU)



R2:
R2#config terminal
R2(config)# router ospf 1
R2(config-router)# redistribute eigrp 100 subnets
R2(config-router)#exit

R2(config)#router eigrp 100
R2(config-router)#redistribute ospf 1 metric 1544 2000 255 1 1500


Untuk R3 gunakan 5 parameter dari interface fa10/0



R3:
R3#config terminal
R3(config)#router ospf 1
R3(config-router)#redistribute eigrp 100 subnets
R3(config-router)#exit
R3(config)#router eigrp 100
R3(config-router)#redistribute ospf 1 metric 100000 100 255 1 1500


Cek tabel routing di R1 dan ping ke alamat 172.16.100.1 kemudian lakukan traceroute.


Trafik dari R1 akan melalui R1-> R2 -> R4, untuk mengubah jalur agar trafik melalui R1 -> R2 -> R3 -> R4 masukkan konfigurasi berikut:

R2(config)#router eigrp 100
R2(config-router)#distance eigrp 90 105

Perintah di atas mengeset Administrative Distance (AD) dari semua rute internal EIGRP menjadi 90 dan semua rute eksternal dari EIGRP menjadi 105 (AD awal 170), yang lebih kecil dari Administrative Distance OSPF (110) -> sehingga link antara R2 & R3 akan lebih dipilih.

Lakukan ping dan tracer dari R1 ke alamat 172.16.100.1


Bagi yang ingin download file EIGRP OSPF Redistribution GNS3 silakan di sini

1 comments

IBU TUTI TKI SINGAPUR November 27, 2016 at 9:01 AM

SAYA SEKELUARGA INGIN MENGUCAPKAN BANYAK TERIMAH KASIH KEPADA AKI NAWE BERKAT BANTUANNNYA SEMUA HUTANG HUTANG SAYA SUDAH PADA LUNAS SEMUA BAHKAN SEKARAN SAYA SUDAH BISA BUKA TOKO SENDIRI,ITU SEMUA ATAS BANTUAN AKI YG TELAH MEMBERIKAN ANKA JITUNYA KEPADA SAYA DAN ALHAMDULILLAH ITU BENER2 TERBUKTI TEMBUS..BAGI ANDA YG INGIN SEPERTI SAYA DAN YANG SANGAT MEMERLUKAN ANGKA RITUAL 2D 3D 4D YANG DIJAMIN 100% TEMBUS SILAHKAN HUBUNGI AKI NAWE DI 085-218-379-259 ATAU KLIK SITUS KAMI PESUGIHAN TAMPA TUMBAL

Post a Comment